Vision HelpDesk – User Images Input Validation Failure (R911-0177)

Type: Input Validation Failure
Location: Remote
Impact: Low
Product: Vision HelpDesk
Website: https://www.visionhelpdesk.com
Vulnerable Version: All prior versions.
Fixed Version: 4.1.2
CVE: -
R911: 0177
Date: 2015-05-23
By: RACK911 Labs

Product Description:

Vision Helpdesk is the only web based Help Desk Software that allows to manage support for multiple companies at one place with single staff portal for all companies and each company having its own client portal.

Vulnerability Description:

Due to an input validation failure, it is possible for a malicious user to remove the profile images belonging to other users without authorization.

Impact:

We have deemed this vulnerability to be rated as LOW due to the fact that no sensitive information can be obtained if this vulnerability were to be exploited.

Vulnerable Version:

This vulnerability was tested against Vision HelpDesk 4.0.2 and is believed to exist in all versions prior to the fixed builds below.

Fixed Version:

This vulnerability was patched in Vision HelpDesk 4.1.2.

Vendor Contact Timeline:

2015-05-17: Vendor contacted via email.
2015-05-17: Vendor confirms vulnerability.
2015-05-23: Vendor issues updates to all builds.
2015-05-23: RACK911 Labs issues security advisory.