Vision HelpDesk – Add Contact Input Validation Failure (R911-0126)

Type: Input Validation
Location: Remote
Impact: High
Product: Vision HelpDesk
Website: http://www.thevisionworld.com/
Vulnerable Version: 3.8.6
Fixed Version: 3.8.8
CVE: -
R911: 0126
Date: 2014-02-14
By: Rack911

Product Description:

Vision Helpdesk is the only web based Help Desk Software that allows to manage support for multiple companies at one place with single staff portal for all companies and each company having its own client portal.

Vulnerability Description:

There is an input validation vulnerability within the add contact function that could allow a malicious user to effectively hijack any other account.

Impact:

We have deemed this vulnerability to be rated as HIGH due to the fact that sensitive information can be obtained.

Vulnerable Version:

This vulnerability was tested against Vision HelpDesk 3.8.6 and is believed to exist in all versions prior to the fixed builds below.

Fixed Version:

This vulnerability was patched in Vision HelpDesk 3.8.8.

Vendor Contact Timeline:

2014-01-26: Vendor contacted via email.
2014-01-26: Vendor confirms vulnerability.
2014-02-14: Vendor issues updates to all builds.
2014-02-14: Rack911 issues security advisory.