cPanel – Mailman Insecure Password Changing (R911-0155)

Type: Content Disclosure
Location: Local
Impact: High
Product: cPanel
Website: http://www.cpanel.net
Vulnerable Version: All versions prior to the fixed builds below.
Fixed Version: 11.43.0.12, 11.42.1.16 & 11.40.1.14
CVE: -
R911: 0155
Date: 2014-05-26
By: Rack911

Product Description:

cPanel is an easy-to-use control panel that gives web hosts and the website owners they serve, the ability to quickly and easily manage their servers and websites. Web Host Manager (WHM) is a part of the cPanel software, often used by resellers and system administrators.

Vulnerability Description:

When an administrator changes the password belonging to a mailing list via WHM, it is possible for a malicious user to obtain the password in plain-text by monitoring the ps output.

Impact:

We have deemed this vulnerability to be rated as HIGH due to the fact that mailman passwords can be easily obtained if a user monitors the ps output in real time.

Vulnerable Version:

This vulnerability was tested against cPanel prior to the fixed versions below.

Fixed Version:

This vulnerability was patched in cPanel 11.43.0.12, 11.42.1.16 & 11.40.1.14.

Vendor Contact Timeline:

2014-04-11: Vendor contacted via email.
2014-04-14: Vendor confirms vulnerability.
2014-05-19: Vendor issues updates to all builds.
2014-05-26: Rack911 issues security advisory.